problem with my bersa .380
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
Like Tree1Likes

problem with my bersa .380

This is a discussion on problem with my bersa .380 within the Handgun Maintenance, Cleaning and Gunsmithing forums, part of the Handguns category; Yesterday I went to the range and my bersa thunder plus .380 performed like the champ that she is. I ...

  1. #1
    Join Date
    Sep 2011
    Location
    houston, texas
    Posts
    16

    Default problem with my bersa .380

    Yesterday I went to the range and my bersa thunder plus .380 performed like the champ that she is. I took her home and cleaned her up. Inserted the empty magazine prior to reassembly to make sure she was good. Then I put her back together. Problem is, I then inserted a magazine with a snap cap to make sure she was functioning well and when I pull the trigger, nothing happens. I manually pulled the hammer back and the trigger jumped forward then reset. I took it back apart to see what was wrong, I pulled the trigger and the hammer cocked back. It was completely dismantled and no magazine in the well. I put the grips on.....nothing. All the parts are there and in the right place. Does anyone have any ideas what could be wrong and whether or not I can fix it myself? Thank you.

  2. #2
    Join Date
    Feb 2012
    Posts
    747

    Default

    I would think that sounds normal . A snap cap or empty round won't eject out of the gun unless u pull the slide yourself

  3. #3
    Join Date
    Sep 2011
    Location
    houston, texas
    Posts
    16

    Default

    I took the magazine out of well with the gun dismantled and pulled the trigger and the hammer cocked back. But with the grips on and no magazine it does nothing.

  4. #4
    Firefighterchen's Avatar
    Firefighterchen is online now OC for Tactical Advantage
    Join Date
    Apr 2011
    Location
    Pasco, Washington, United States
    Posts
    5,094

    Default



    7 minute mark. Try that, see if it helps.
    “One of the illusions of life is that the present hour is not the critical, decisive one.” – Ralph Waldo Emerson

  5. #5
    Join Date
    Apr 2012
    Location
    Houston, Tx
    Posts
    216

    Default

    Not sure I am understanding but it sounds like the trigger is doing nothing when no mag is in it as should be the case due to the magazine disconnect safety.
    "One cannot restrict the defiant by constraining the compliant."
    Project One Million:Texas - Click here and Join NRA Today!
    Suggestions by Domineaux | Texas Gun Forum

  6. #6
    Join Date
    Feb 2010
    Location
    Knox TN
    Posts
    1,638

    Default

    Rack the slide with mag in, then release it with no rds in the gun, then get a bic pen and insert the blunt end first into the barrel, and pull the trigger, the pen should fly away, 2 to 3 ft, then try it with no mag, it been a while since I messed with a 709, don't remember if they fire with the mag out?

  7. #7
    Join Date
    Sep 2011
    Location
    houston, texas
    Posts
    16

    Default

    It is actually acting almost as if the magazine disconnect safety is reversed. That is the simplest way I can describe it.

  8. #8
    Join Date
    Feb 2010
    Location
    Knox TN
    Posts
    1,638

    Default

    Quote Originally Posted by wa5emt View Post
    It is actually acting almost as if the magazine disconnect safety is reversed. That is the simplest way I can describe it.
    Your saying it will fire with a rd in the chamber and no mag, but with the mag in no bang???.....now thats strange, I'm not real good with fly by wire, hard to say without the gun in front of me, I'm sure one of the good smiths on hear that know Bersas can help, if not google up bersa 380 disasembly/assembly and see if one of the videos is detailed enough to follow

  9. #9
    Join Date
    Jan 2008
    Location
    Oakland county, MI
    Posts
    72

    Default

    get it fixed? Very easy to move the lever out of postition when you remove the grips.
    If you served in any branch of the Military, THANK YOU

  10. #10
    Join Date
    Jun 2010
    Location
    Virginia
    Posts
    39

    Default

    Try complete dismantle .. then REMOVE any mag. and then reassemble. My Bersa A-383 has problems if you try to assemble it with a mag. in place.
    Hope this helps.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •