Beretta PX4 Storm subcompact not feeding completely?
Results 1 to 9 of 9

Thread: Beretta PX4 Storm subcompact not feeding completely?

  1. Beretta PX4 Storm subcompact not feeding completely?

    I traded for a Beretta PX4 Storm subcompact today. The guy I got it from had only put 1 box of ammo through it of which brand I forgot to ask and said it shot fine. I took it out and put a little over 3 boxes of 50 count of Federal, Tula, Monarch, and some Winchester 147gr JHP. Aside from the Winchester all ammo was 115gr.

    The first 2 mags I had once each what I think would be called a stovepipe. A couple shots into the mag a round loaded but did not go completely into the chamber. After the first 2 mags where this happened the gun shot fine the rest of the time. That was Federal and Tula those happened on.

    The only thing I can think that might have been different after the first 2 mags was I don't think I slapped them in so I'm thinking it's possible they just weren't in tight enough. From then on I would slap the mag to make certain it went in tight.

    Have you guys experienced similar situations with new guns or Berettas specifically?

  2.   
  3. #2
    I own the same gun. 1500 rounds with no hang ups other than when I used Russian ammo once.

    Clean and oil it and operate the slide some and break it in a little. Maybe lock the gun open for a few hours to break in the recoil spring a little.

    Also make sure you aren't limp writing it when shooting. This can happen if your wrist doesn't stay straight after easy shot and the recoil from the gun isn't absorbed and the next round won't load properly.

    If you still have problems send it to the factor and don't mention you used stell case ammo

  4. Beretta might care what kind of ammo I used but a high quality gun should be able to shoot any kind.

    I know it had been cleaned before being fired the first time and them cleaned again before I got it. I could tell it was overlubed also. Typically I clean with Ballistoil, wipe everything down really well and then put just a tiny bit in the rail grooves and the other places where metal meets metal. When I got the pistol it had oil almost leaking out of it.

    Normally I'd be more concerned but since I put about 125 or so more rounds through it after those and the fact that the first 50 rounds shot fine I'm really leaning toward the magazine just not being in tight enough. Every time after those first 2 when I'd slide the mag in and slap it into place I had no issues.

  5. Also might check the ramp leading to the barrel. I polished all of my guns with a dremmel and jewelers rouge. Takes 5 minutes. Keep the gun clean. Good luck.

  6. #5
    It could be the ammo, it could be limp wristing, it could be the ramp needs polishing. try addressing these and report back

  7. #6
    I have both the .40S&W and the 9MM of the PX4C and never had any issues with ammo. Take a look at the feed ramp. If there is any unusual discolorations or you notice some imperfections, polish the ramp. The other item that has been mentioned is limp wristing the gun. Try a firmer grip and keep the strong hand wrist locked. The smaller full caliber guns are notorious for feed and failure issues when you're grip is sub par.
    Kevin - NRA Life Member
    2nd Amendment = Freedom from Tyranny

  8. just got my px4 subcompact in 9mm this weekend. Put 300 rounds of 4 different ammo's through it and NO failures, not one. I love the feel of the gun but it is a bit clunky to carry.

  9. I'll put some more rounds through it when I get a chance but I'm pretty sure I just needed to make sure the magazine was in tight. I know for sure the first couple I just pushed it in with my thumb. After those I'd push it in and slap it and had no failures.

    I stripped it and cleaned it thoroughly after shooting.

    As far as polishing the feed ramp I don't understand why I would want to or needto do that on a pistol of that price and quality, especially since it has a tilting barrel that is supposed to make feeding easier. I'm really not a family of that idea. If need be I'll send it back to get checked out but I'm not a fan of the idea of taking a dremmel to a brand new $500+ gun.

  10. #9
    Join Date
    Aug 2011
    Location
    North Carolina
    Posts
    181
    I used to own the Beretta PX4 Storm Subcompact 9mm and I experienced a Failure to Feed in two instances. First was when I manually raked the slide and it didn't fully chamber the round - I chalk this up to me being to light with the return to battery. My second failure to feed though was a little perplexing as what happened is no matter how many times I attempted to chamber 1 particular 9mm round it simply would not fully chamber. I eventually took the round and ran it through my M&P 9 and it chambered/fired perfectly. I chalk that up to a bad cartridge and perhaps the M&P was just a little more forgiving on chamber dimensions. Possibly you just happened to have two rounds that were slightly out of spec? FYI the Federal Champion is the ammo type that I had my failure with.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Quantcast