LaserMax problem
Results 1 to 8 of 8

Thread: LaserMax problem

  1. #1

    LaserMax problem

    Can anyone tell me what might be wrong with a LaserMax that doesn't work or seldom works? I have an LCP that came with the LaserMax. At first it worked fairly well, but now hardly at all. I've tried changing the battery and that doesn't seem to be the problem. Once in awhile it will come on for a second or less and then goes off. Mostly it doesn't come on at all. It's not something I depend on, but since it's on there, I'd like for it to work. And my holsters are made specifically for an LCP w/LaserMax.

  2.   
  3. My LCP came with a Lasermax as well. I worked for about 2 days. Sent it back and they sent another which worked for less time than the first. Took it off and its sitting on a shelf somewhere. Too much trouble to screw around with.

  4. #3
    I was thinking about a lasermax for my S&W SVE9, but after reading these comments I am rethinking about getting some thing else. But first have to do something about the heavy trigger pull almost 18 lbs.

  5. #4
    I have a lasermax guide rod. The only thing I can say is that I've had to deal with lasermax once. They are awesome to deal with. Fixed my problem and it's been great ever since.

  6. I got a ruger LC9 with the lasermax on it and had the same problem. I took the batt out and noticed the silicone plug in the batt spring(like a maglight) was interfering I gently stretched the spring a little for more tension on the batt and snipped the top of the silicon plug so it wouldnt stick up so far. Only took it out one more time but it worked for the 50 or.so rounds put through it. Hope this helps so far so good.

  7. #6
    Join Date
    Aug 2013
    Location
    Brazil, Indiana, United States
    Posts
    2
    Quote Originally Posted by cmputerbiz View Post
    My LCP came with a Lasermax as well. I worked for about 2 days. Sent it back and they sent another which worked for less time than the first. Took it off and its sitting on a shelf somewhere. Too much trouble to screw around with.
    Same here, I took mine off, lost a little cool factor...but if I had to pull it out for protection...coolness would be the last thing on their mind.
    Dion0.45

  8. #7
    Join Date
    Feb 2013
    Location
    The Lowcountry of South Carolina
    Posts
    2,039
    I would call the company. I have one (add-on, not factory) for my LC9, and have had no issues. When I'm at the range I try to shoot about 20-25% using the LM just because it's there.
    Chief

  9. #8
    Update: I contacted their warranty department online, waited about a week, nothing. Emailed them. Shelly apologized and said she would forward my problem to the warranty department. Waited another week, nothing. Emailed Shelly again, said I'd still heard nothing and that I was a little surprised because I'd heard good things about their customer service. She apologized again and said she would get on it right now. Within 10 minutes, James in the warranty department called me, apologized all over himself, said he would send a new one immediately along with a postage paid label to send the old one back. Had a new one within two days. But no label. Called, but James wasn't there. Today I got another package from them, a nice cap. Still no label. Will try calling again tomorrow. I'm guessing they're probably not too worried about getting it back though.
    But all in all I would recommend their service department, I just think they got wires crossed somewhere.
    Do Not Meddle In The Affairs Of Dragons ~ For You Are Crunchy And Good With Ketchup

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Quantcast